Back to overview
Degraded

SEO Data Provider Outage

Mar 05 at 08:02am EET
Affected services
Backend Service

Resolved
Mar 05 at 11:17am EET

All services are back to normal.

Created
Mar 05 at 08:02am EET

One of our data providers is experiencing issues which impacts SEO research module. We're actively working with them on restoring the functionality.